Elementor编辑器环境要求

在刚开始使用Elementor时,有些朋友可能会出现一些奇怪的问题,比如说某些功能无法使用、布局错乱、速度慢等,无论怎样测试都无法修正,如果不是操作失误出现这种情况的话,很可能是因为你的网站环境不符合Elementor的最低要求

因为Elementor中有非常多的新特性,比如鼠标拖拽、实时编辑、右键菜单、响应式等,这些特性中很多都采用了最新的技术,所以说它对环境的是有一定要求的,如果达不到最低的标准,那么很可能你的站点就不适合使用Elementor,需要进行升级才能使用

接下来我们就看一下Elementor对环境有哪些要求

1.PHP版本 7.0以上

Elementor要求最低版本为PHP7.0,有些人可能正在使用5.4以上的版本也能使用,不过Elementor团队已经声明不再维护这些版本的适配,可能会出现漏洞或者错误,所以PHP版本最好安装为7.0以上

如果你是自己用服务器搭建的话那么很简单,只需要升级PHP就行了,如果使用的虚拟主机则需要询问主机商能不能升级或者更换版本

 

2.MySQL 5.6以上

Elementor要求MySQL 5.6,如果低于这个版本,同样需要升级软件

 

3.WordPress内存限制提升

Elementor要求WordPress内存限制不能小于64MB,最好在128MB以上

修改方法:打开网站根目录的 wp-config.php 文件,加入以下语句 define( ‘WP_MEMORY_LIMIT’, ‘128M’ );

 

4.浏览器要求

Elementor建议使用这3个浏览器,Chrome、Firefox和Safari,如果使用其他浏览器,尤其是IE浏览器,会出现一些兼容性的问题

当然,这些仅仅是在页面编辑时的要求,你使用Elementor创建的页面是兼容大部分主流浏览器的

 

只要符合以上要求,大部分使用Elementor时遇到的BUG都能解决

发表评论